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What is PabloDraw

PabloDraw is what is called an ‘Ansi Editor’.  It can be used to create and edit Ansi coloured text files.  Nowadays, these files usually are drawings of fictional characters, or a logo of some sort to promote a telnet board or group.

What is Ansi?  Ansi is essentially coloured text, which is best represented in a mono space font, such as used in a DOS, or command line.  

Instead of going into a long schpeal about the history of Ansi, I will just say that Ansi coloured text is used on the internet today, by what is known as telnet boards.  These boards use the same technology to display information on the screen as the old Bulletin Board Systems (better known as BBS’) that used to be very prevalent back in the late 80’s and 90’s.
System requirements

Minimum requirements

· Windows 98se/Me/NT/2K/XP, or Windows 98 with Accessibility update

· DirectX 7.0 or greater (for full-screen mode)

Using PabloDraw

PabloDraw is best used with the keyboard.  It has been designed to closely match the same type of drawing programs that were used in DOS in the 90’s.  However, there are many Windows-like features that give it that extra ‘kick’ into the next millennium, such as the snazzy GUI interface, and multi-user capabilities.
Your first drawing

PabloDraw’s default configuration is set up so that you can start drawing very quickly.  There should be a blinking ‘Cursor’ in the main screen when you start it up, which you can move with the cursor keys, home/end/pgup/pgdn, etc. 
You can type in the screen just like a normal text editor.  To make drawing easier, there is the following toolbar at the bottom of the screen:
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This depicts the current quick-characters that you can use by pressing the F1-F12 keys on the keyboard.  These default characters are usually used for shading and shaping objects on the screen.  You can change these by pressing Alt+F1-F12, and Ctrl+F1-F12.  The default (shown) is Alt+F6.  

Note: 
In Windows 98, and ME, you must press Shift+F6 to get back to the default character set, since the operating system does not allow applications to use this system-defined key.  In Windows NT, 2000, and XP Alt+F6 should work fine.

In Ansi, there are also colours.  You can use the background/foreground colours in combination with the characters that you put on the canvas to produce shading effects to detail your drawing.  You can change the current colour by using the mouse with the colour toolbar shown below:
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You can change the foreground colour by clicking the left mouse button on one of the colours, or press Ctrl+Up/Down.  To change the background colour, use the right mouse button, or press Ctrl+Left/Right.  You can also press Ctrl+1-8, or Alt+1-8 to quickly change to a colour, and again to change it’s intensity from normal to bright.

It is often useful when you are making a large drawing to use the preview window to ensure your drawing is proportional.  To show the preview window, select View->Preview Window, or press Alt+V.

Drawing with others

One good way to learn how to draw real good, real fast is to watch someone else draw!  And with PabloDraw, you can do this without driving 10,000 km to where your Ansi Idol lives (or across town to your friends house).  This is called Multi-User Drawing, and PabloDraw allows a virtually unlimited number of users to connect to one server, all drawing at the same time.  
There are two parts to drawing with a friend.  One of you must be a ‘server’, and one a ‘client’.  If you want more people to join, they can just connect to the same server.  To start a server, go to Tools->Start Server.  It will give you the following dialog:
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Here you get to choose an ‘Alias’ for yourself to identify you when you are chatting, and on the User List.  The Port is a communications port to use through the Internet to connect to.  When someone connects to your server, they must specify the same port you have chosen to use.  The default is 700.

When you are connecting to a server, you get the following:
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Here you get the same options, however you must also specify the IP address of the machine that is running the server.  The Port number you choose must match the same port number that the server was started with.
Note:
When you are connected to a server, everything you do will be shown to all other users connected to that server.  So if you clear the screen, then it will clear the screen of everyone connected to the same server.  This also applies for loading, block cut/copy/paste/fill, etc.
Keyboard reference

Global keys
	Key
	Description

	Arrow Keys
	Move the cursor up/down/left/right in the canvas

	Home/End
	Move the cursor to the beginning/end of the screen, and again to the beginning/end of the canvas

	PageUp/PageDown
	Move the cursor up or down one screen of the canvas

	Ctrl+PageUp/
Ctrl+PageDown
	Move the cursor to the first row or last row of the canvas

	Alt+L
	Load/Open a file

	Alt+S
	Save to a new file (with prompt)

	Ctrl+S
	Save current file (without prompt)

	Alt+C
	Clears the canvas

	Alt+B
or Shift+Arrows
	Select a block, puts canvas in block mode

	Alt+F1-F10
	Select character sets 1 – 10

	Ctrl+F1-F10
	Select character sets 11 – 20

	F1 – F12
	Draw a character from the currently selected character set

	Ctrl+Right/Left
	Change the background colour

	Ctrl+Up/Down
	Change the foreground colour

	Alt+U
	Use the colour under the current cursor position

	Alt+M
	Switch from 8x16 font to 8x8 font

	Ins
	Toggles Insert mode

	Alt+Left/Right
	Insert/Delete a column at the current cursor position

	Alt+Down/Up
or Alt+I/Y
	Insert/Delete a row at the current cursor position

	Ctrl+V
or Shift+Ins
	Pastes the data on the clipboard starting at the current cursor position

	Ctrl+Z or Alt+R
	Undo previous action

	Ctrl+Y
	Redo previous action


Keys in block mode
Block mode is the mode in which you are selecting an area of the canvas.  In this mode, you cannot draw to the canvas and have only the following functions:
	Key
	Description

	B
	Brings up the block menu

	D
	Deletes the currently selected block, shifting everything right of the block into the deleted area

	E
	Erases the currently selected block without changing any other data

	F
or Ctrl+F
	Shows pop-up menu of fill options; Character, Attribute, Back, Fore, and Both.

	Ctrl+X
or Shift+Del
	Cut the current block selection into the clipboard and exits block mode

	Ctrl+C
or Ctrl+Ins
	Copies the current block selection into the clipboard and exits block mode

	C
	Copies the selection into the buffer and goes into Paste Mode

	M
	Moves the selection into the buffer and goes into Paste Mode

	
	

	Esc
	Escapes out of block mode without making any changes


Keys in paste mode

Paste Mode is where you have selected a block and chose to Copy it or Move it
	Key
	Description

	Arrow Keys
	Move the block around

	X
	Flips the block in the buffer horizontally

	Y
	Flips the block in the buffer vertically

	R
	Rotates the block in the buffer clockwise

	U
	Toggles between showing the block in the buffer on top of the canvas, or behind the canvas.

	T
	Toggles between showing the background picture through the empty parts of the block

	S
	Stamps the block in the current position

	Enter
	Pastes the block in the current position and exits paste mode

	Esc
	Exits out of paste mode without making any changes


Contact

Pablo Draw is most likely the only Ansi editor out there for windows and has multi-user capabilities.  This hopefully will allow the Ansi/Ascii scene rise to new levels of co-operative artwork and collaboration (and to give it a good swift kick in the ass).  
Internet contact

You can get more information, ask questions, submit bugs, or get the latest version of PabloDraw at:

http://pablo.etoxn.ca
About the author
I have been part of the ANSI/ASCII community since 1995, and part of the ‘scene’ in general since 1992.  I didn’t realize that when I started working on ‘pablo’ in Mistigris, that I would still be working on it today.

I was in such groups as PiXEL, Sonic Equinox, and Mistigris.  For these groups, I did many graphical application generators, demos/loaders, etc.  I was even part of iCE for a while, but didn’t code anything for them. Though, I did contribute some of my pencil art and did some tiles.
The latest incarnation of PabloDraw (for windows), started out as a prototype in 1999, but has only been in production since 2001.  I only work on it in my spare time, and do it mostly for fun.  
Change log
Ideas for future versions

These are some things that I’m thinking of implementing in future versions (in no particular order).  If any of these are of special interest to you, send me an email (see the ‘Contact’ section)

NOTE!!  The current MFC-based code is no longer being developed.  A new, .NET version is now under development.
Ansimation support using a frame-based interface

SAUCE support

XBIN/ADF/IDF support, allowing changing of fonts and palette

Showing the cursor of each user connected to the server on the canvas, with user-definable colours.

Ansi viewing mode that loads up a ZIP directly, and displays thumbnails for each file (for viewing packs)
Mouse-driven Ansi drawing (like a paint program)
Multi-user RIP editing (Vector Formats)

Multi-user Hi-resolution editing (Raster Formats – BMP/JPG/PNG)

DOS simulated font – a font for windowed mode which simulates the aspect & characteristics of the DOS video mode. 
2.0.7.44 – December 28, 2003

Added ITP-Draw compatibility mode when selecting colors (ctrl+arrows are switched)

Bug: When saving ansi, PabloDraw will now set the start color so it loads properly in aciddraw, and some viewers

Bug: Saving to binary skipped the last line

Bug: More general fixes to the multi-user communications to be less bug-prone

When bringing the PabloDraw window back into the foreground, it will set the focus to the last focused control (so if you were in the chat window before, it will when you alt+tab back to Pablo).

When someone loads a file or clears the screen in multi-user mode, pressing SAVE will not overwrite your old file.

Added Amiga font support (View->Amiga font)

Added block flip/rotate character mappings (so the image will remain intact when flipping/rotating)

Bug: Fixed full-screen mouse cursor.  It sometimes re-positioned the cursor even if not moving the mouse 
2.0.6.35 – August 16, 2003
Can now hold down shift and use arrows/paging/home/end/return/backspace without any funky characters showing up (Reported by: fille)

Made multi-user drawing faster by compressing the data transferred.  Currently using the ANSI encoding to compress before transferring.

Added Alt+U function to pick up colour under the cursor

Added Block Character/Attribute/Back/Fore fills

Added Block Delete/Erase/Flip/Rotate
Added Block Copy/Paste between windows

Added Preview Window

Now supports copy/paste of blocks similar to dos drawing apps, using ‘C’ to copy or ‘M’ to move. (Ctrl+X/C/V work the same as windows apps still)
Added insert mode so when you type it will move the rest of the line (Ins)

Added a names list when connected to a server

Made TAB switch between drawing and the chat window.  In full-screen it will hide the chat window to maximize drawing space

Added 200 level UNDO/REDO (Alt+R or Ctrl+Z/Ctrl+Y).  In multi-user mode, the undo buffer will be shared among all users for now, to avoid complications of having to modify each local undo history based on what changes other people make.
Fixed load/save dialog not showing up in Win9x

Added iCE colours & blinking text.  In blink mode (non-iCE) the background will only cycle the first 8 colours
Fixed loading BIN files with larger widths when connected to a server

Added Full-Screen mode (Alt+Enter) so that you can draw with the same aspect ratio as DOS.  (requires DirectX 7, and 640x400x16 mode support)

Added Alt+C to clear the canvas

Can now load unix-type ansi/ascii files

Switched to an SDI interface (only one ansi can be loaded per instance of pablodraw) to simplify the interface
Fixed many, MANY multi-user bugs to eliminate any crashing/freezing

Now safely disconnects a user if the other end has crashed or disconnected unexpectedly
External DLL’s are now no longer required (except DirectX)

Created User Guide document (hmm.. overkill? Probably.. but it was fun)

The chat window will now auto-scroll in 9x/NT

Mouse now works the same as dos drawing apps when in full-screen mode

Can now Cut ‘n Paste between different instances of PabloDraw using the windows clipboard (use Ctrl+C, Ctrl+V)

2.0.5 – February 10, 2002
Added CHAT interface - Win9x/NT users won't have auto scrolling for now.

Added ASCII/BIN saving and loading (including file associations)

Fixed crash when starting up pablo

Added rudimentary block functions (cut, copy, paste)  Acts like normal windows programs for now

Fixed some other small bugs

2.0.3 – November 7, 2001

Added Colour Toolbar (switch with Ctrl+Up/Dn/Lt/Rt)

Added Character Set Toolbar (switch with Alt+F1-F12 & Ctrl+F1-F12)

Switched over to VS.NET (using MFC v7.0 now)

Added installer redistributable

Can now load *.ANS, *.ASC from windows explorer

2.0.2 – September 23, 2001

Added ANSI saving/loading

'Halfies' added (F5 - F8)

Bug fixes with multi-user

Only allocates memory for the canvas as needed

80x50 mode support (alt+m to switch)

More aciddraw-ish keys (alt+L for load, alt+S for save, etc)

optimized client/server transfers on initial connect

font.fnt file no longer needed - embedded into .exe
2.0 – 1999
Original prototype version

Crude multi-user support

